Documentation: fix documentation AsciiDoc links for external urls

Turns out that putting 'link:' before the 'http' is actually superfluous in AsciiDoc, as there's already a predefined macro to handle it. "http, https, [etc] URLs are rendered using predefined inline macros." http://www.methods.co.nz/asciidoc/userguide.html#_urls "Hypertext links to files on the local file system are specified using the link inline macro." http://www.methods.co.nz/asciidoc/userguide.html#_linking_to_local_documents Despite being superfluous, the reference implementation of AsciiDoc tolerates the extra 'link:' and silently removes it, giving a functioning link in the generated HTML. However, AsciiDoctor (the Ruby implementation of AsciiDoc used to render the http://git-scm.com/ site) does /not/ have this behaviour, and so generates broken links, as can be seen here: http://git-scm.com/docs/git-cvsimport (links to cvs2git & parsecvs) http://git-scm.com/docs/git-filter-branch (link to The BFG) It's worth noting that after this change, the html generated by 'make html' in the git project is identical, and all links still work. Signed-off-by: Roberto Tyley <roberto.tyley@gmail.com> Signed-off-by: Junio C Hamano <gitster@pobox.com>

Roberto Tyley committed Feb 18, 2014 at 21:42 UTC 2df85669d16703714968572937ebb67a31241ca3
6 files changed +9 -9
Documentation/git-cvsimport.txt
+2 -2
@@ -21,8 +21,8 @@ DESCRIPTION
21 *WARNING:* `git cvsimport` uses cvsps version 2, which is considered
22 deprecated; it does not work with cvsps version 3 and later. If you are
23 performing a one-shot import of a CVS repository consider using
24 -link:http://cvs2svn.tigris.org/cvs2git.html[cvs2git] or
25 -link:https://github.com/BartMassey/parsecvs[parsecvs].
24 +http://cvs2svn.tigris.org/cvs2git.html[cvs2git] or
25 +https://github.com/BartMassey/parsecvs[parsecvs].
26
27 Imports a CVS repository into Git. It will either create a new
28 repository, or incrementally import into an existing one.
Documentation/git-filter-branch.txt
+2 -2
@@ -436,7 +436,7 @@ git-filter-branch allows you to make complex shell-scripted rewrites
436 of your Git history, but you probably don't need this flexibility if
437 you're simply _removing unwanted data_ like large files or passwords.
438 For those operations you may want to consider
439 -link:http://rtyley.github.io/bfg-repo-cleaner/[The BFG Repo-Cleaner],
439 +http://rtyley.github.io/bfg-repo-cleaner/[The BFG Repo-Cleaner],
440 a JVM-based alternative to git-filter-branch, typically at least
441 10-50x faster for those use-cases, and with quite different
442 characteristics:
@@ -455,7 +455,7 @@ characteristics:
455 _is_ possible to write filters that include their own parallellism,
456 in the scripts executed against each commit.
457
458 -* The link:http://rtyley.github.io/bfg-repo-cleaner/#examples[command options]
458 +* The http://rtyley.github.io/bfg-repo-cleaner/#examples[command options]
459 are much more restrictive than git-filter branch, and dedicated just
460 to the tasks of removing unwanted data- e.g:
461 `--strip-blobs-bigger-than 1M`.
Documentation/gitcore-tutorial.txt
+1 -1
@@ -1443,7 +1443,7 @@ Although Git is a truly distributed system, it is often
1443 convenient to organize your project with an informal hierarchy
1444 of developers. Linux kernel development is run this way. There
1445 is a nice illustration (page 17, "Merges to Mainline") in
1446 -link:http://www.xenotime.net/linux/mentor/linux-mentoring-2006.pdf[Randy Dunlap's presentation].
1446 +http://www.xenotime.net/linux/mentor/linux-mentoring-2006.pdf[Randy Dunlap's presentation].
1447
1448 It should be stressed that this hierarchy is purely *informal*.
1449 There is nothing fundamental in Git that enforces the "chain of
Documentation/gitcvs-migration.txt
+1 -1
@@ -117,7 +117,7 @@ Importing a CVS archive
117 -----------------------
118
119 First, install version 2.1 or higher of cvsps from
120 -link:http://www.cobite.com/cvsps/[http://www.cobite.com/cvsps/] and make
120 +http://www.cobite.com/cvsps/[http://www.cobite.com/cvsps/] and make
121 sure it is in your path. Then cd to a checked out CVS working directory
122 of the project you are interested in and run linkgit:git-cvsimport[1]:
123
Documentation/gitweb.txt
+1 -1
@@ -84,7 +84,7 @@ separator (rules for Perl's "`split(" ", $line)`").
84
85 * Fields use modified URI encoding, defined in RFC 3986, section 2.1
86 (Percent-Encoding), or rather "Query string encoding" (see
87 -link:http://en.wikipedia.org/wiki/Query_string#URL_encoding[]), the difference
87 +http://en.wikipedia.org/wiki/Query_string#URL_encoding[]), the difference
88 being that SP (" ") can be encoded as "{plus}" (and therefore "{plus}" has to be
89 also percent-encoded).
90 +
Documentation/technical/http-protocol.txt
+2 -2
@@ -500,7 +500,7 @@ TODO: Document this further.
500 References
501 ----------
502
503 -link:http://www.ietf.org/rfc/rfc1738.txt[RFC 1738: Uniform Resource Locators (URL)]
504 -link:http://www.ietf.org/rfc/rfc2616.txt[RFC 2616: Hypertext Transfer Protocol -- HTTP/1.1]
503 +http://www.ietf.org/rfc/rfc1738.txt[RFC 1738: Uniform Resource Locators (URL)]
504 +http://www.ietf.org/rfc/rfc2616.txt[RFC 2616: Hypertext Transfer Protocol -- HTTP/1.1]
505 link:technical/pack-protocol.html
506 link:technical/protocol-capabilities.html